How To: Update the BIOS on an MSI motherboard

MSI Z87-G41
MSI Z87-G41

First of all, MSI documentations SUCKS, M-Flash SUCKS. Few hours of research and possibly luck I was able to update the BIOS on my new system. M-Flash would freeze my computer in the BIOS screen when I selected the new BIOS version. This caused a few missing heartbeats but it did not break my motherboard, it just never flashed. I formatted the flashdrive to fat32 as many websites say but nothing worked. I placed the files on the root of the flash drive and could see them but selecing them would freeze the bios.

Disclamer: I am not responsible for errors or damages that may occur from following these instructions. I am posting this for future documentation, for other to see and because these steps worked for me. Be sure you know what you are doing before attempting these instructions.

Update 8/15/2014 BIOS v 1.8 – The Bios seems to be doing ok, although when I first booted back into the BIOS my Logitech USB keyboard (With unifying receiver ) Didnt seem to be working… So I plugged in a wired USB and that worked just fine. I booted into Windows and installed the latest Chipset Drivers and Windows Management Engine Drivers and now I can boot into the bios with the Logitech Keyboard. I will update the site if anything goes wrong or I start to have problems.

P.S. I used the MFlash utility since I’ve heard the LiveUpdate is more prone to brick your motherboard and these are the methods MSI suggets on their site. The Mflash seemed to actually work. I also read to reset your CMOS after the flash to clear any previews settings. Good Luck!

Youtube Video of this tutorial!

Update 2/27/2014 Beware of BIOS v1.5: I turned on my computer to find it would not get past the BIOS. I would press Del and it would say “Entering setup” but nothing would work. then it wouldnt get past the Numbers/letters on the bottom right of the corner, it would get stuck on A2 on the bottom right corner. I reset the BIOS Multiple times and it would boot but then rebooting again it got stuck on the BIOS. I also have a video of the BIOS screen all glitchy. I went back to BIOS 1.4 which feels much more stable and booting isnt a problem anymore. Please leave a comment if you have had similar problems! See YouTube Video of the glitchy BIOS

Materials and Files: 

– 4gb DataTraveler G3 by Kingston.

– Latest BIOS for your motherboard (double & triple check otherwise it will break your motherboard)

– Rufus USB Boot utility http://rufus.akeo.ie/

Steps:

1 ) Creat USB Bootable Drive with Rufus.

2 ) Download BIOS (E7850IMS.130) and Flash utility(AFUDE238.exe) and extract to the root of the flash drive.

Note: these are going to change depending on your bios and flash utility.

3 ) Make sure your motherboard is on UEFI + BIOS . Press Del at boot and then go to settings>Boot>BootModeSelect>Legacy + UEFI. Stick flash drive on the back of the computer to one of the USB ports on the motherboard.

4) Press F11 to select boot device at startup, select the flash drive that DOESN’t have UEFI next to it.

5) When the flashdrive boots into the C:\ prompt type in afude238 e7850ims.130  Don’t forget the space between those two words.

6) Once you are sure the bios is done flashing – when the screen displays C:\ at the bottom left of the screen. Reboot the computer. I pressed the reset button.

Resources: 

Post by Slaymante on the link below

http://www.tech-forums.net/forums/f77/msi-live-update-rubbish-so-how-do-i-update-my-bios-218681/

Shitty documentation on MSI website

http://msi.com/service/biosupdate/

Rufus Settings:

1

 

 

 

 

 

 

Folder Structure:

2

BIOS Commands:

3